جزئیات آسیبپذیری
CVE-2026-121652
AWS maplibre-gl-js-amplify
Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering
CVSS 4.0
4.8متوسط
نمای کلی
اکسپلویتهای عمومی
اخبار مرتبط
خط زمانی
خلاصهی فارسی
خلاصهی فارسی برای این آسیبپذیری هنوز تهیه نشده است.
شرح رسمی (انگلیسی)
Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.
امتیازهای CVSS
| امتیاز | نسخه | منبع | بردار |
|---|---|---|---|
| 4.8متوسط | 4.0 | CVEProject cvelistV5 (CNA) (AMZN) | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N |
| 5.4متوسط | 3.1 | CVEProject cvelistV5 (CNA) (AMZN) | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N |
محصولات آسیبپذیر
| فروشنده | محصول | نسخهها | منبع |
|---|---|---|---|
| AWS | maplibre-gl-js-amplify | v < 4.0.3 | CVEProject cvelistV5 (CNA) |
منابع و راهنماها
۳- https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3 release-notespatch
- https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9 third-party-advisory
- https://aws.amazon.com/security/security-bulletins/2026-167-aws/ vendor-advisory
اطلاعات
- تاریخ انتشار
- ۱۴۰۵/۰۸/۱۲
- آخرین بهروزرسانی
- ۱۴۰۵/۰۸/۱۲
- وضعیت
- PUBLISHED
- صادرکننده (CNA)
- AMZN
- اولویت کلون
- بهزودی
پیشبینی بهرهبرداری (EPSS)
امتیاز EPSS برای این CVE هنوز منتشر نشده است.
ارزیابی SSVC (CISA)
- Automatable
- no
- Exploitation
- none
- Technical Impact
- partial
ضعفها (CWE)
- CWE-79Improper neutralization of input during web page generation ('cross-site scripting')